I upgraded my project appdriver to Spring 3.2.9.RELEASE and so had to change the versions of Spring Data also.

It took a while to find the right combination of versions, some Spring projects use completely different version numbers.

As far as I know, there exists no compatibility matrix anywhere. The following table shows a combination of versions that fit together, I hope it helps :

artifact version
spring-aop 3.2.9.RELEASE
spring-aspects 3.2.9.RELEASE
spring-beans 3.2.9.RELEASE
spring-context 3.2.9.RELEASE
spring-core 3.2.9.RELEASE
spring-data-commons 1.8.0.RELEASE
spring-data-jpa 1.6.0.RELEASE
spring-data-rest-core 2.1.0.RELEASE
spring-data-rest-webmvc 2.1.0.RELEASE
spring-expression 3.2.9.RELEASE
spring-hateoas 0.12.0.RELEASE
spring-jdbc 3.2.9.RELEASE
spring-orm 3.2.9.RELEASE
spring-plugin-core 1.1.0.RELEASE
spring-test 3.2.9.RELEASE
spring-tx 3.2.9.RELEASE
spring-web 3.2.9.RELEASE
spring-webmvc 3.2.9.RELEASE

Comments

comments powered by Disqus